TurningPoint Scheduled Update
Incident Report for Turning Technologies
Resolved
This incident has been resolved.
Posted Jun 16, 2018 - 20:55 EDT
Identified
We are currently performing maintenance on our TurningPoint servers that may cause intermittent outages throughout the day. Durning any outages, access to both your TurningPoint account and TurningPoint mobile responding will be unavailable. We apologize for any inconvenience this may cause.
Posted Jun 16, 2018 - 18:25 EDT
This incident affected: Student Account (Student Responding), Instructor Account (Live Polling), and Administrator Account.